Forum: Hardware Technical Support - Topic: DDJ WeGo not working with VDJ Pro

Use this forum if you have any question or difficulty using a USB or MIDI controller.
For general troubleshooting and controller configuration, please see Config & Troubleshooting.
(for problem with VirtualDJ 8, please use the dedicated VirtualDJ 8 Bug Report forum)
Il forum di VirtualDJ
Hardware Technical...
DDJ WeGo not...


Autore - Topic: DDJ WeGo not working with VDJ Pro -

Shippio
LE user
Member since 2012

Inviato Fri 05 Oct 12 @ 11:29 am
I already own Virtual DJ Pro and just purchased the DDJ WeGO. However I want to be able to take full advantage of my Virtual DJ Pro. However once I install the VDJ LE I can not find the mappings on my pc, neither does VDJ Pro respond to the MIDI Controller. Is there any easier solution than to map the controller for Pro. And if so, how can I embed the light effects of the controller into this mapping? (I.E. make the play button flash once a new track is loaded on the MIDI Controller)

groovindj
PRO Infinity
Member since 2007

Inviato Fri 05 Oct 12 @ 11:59 am
What version of VDJ Pro are you using (and why haven't you registered it)?

The WeGo is definitely supported in the latest version. I just checked.

PhantomDeejay
PRO Infinity
Member since 2007

Senior staff
Inviato Mon 08 Oct 12 @ 7:10 am
Since you own PRO Full you should register your serial number on your profile HERE and then download the latest version (7.1) from HERE.
This way you'll be able to work with DDJ-WeGo and your copy of PRO

lucian1987
LE user
Member since 2012

Inviato Thu 21 Mar 13 @ 6:48 pm
Same it happend to me Pro v 7.04 does not respond to wego like LE does?
How can we fix it.

nindoz
Home user
Member since 2012

Inviato Tue 16 Apr 13 @ 1:59 pm
one thing you could do (which worked for me) was to go to the midi mapper but it can get a bit complicated

Deco_d1
PRO Infinity
Member since 2014

Inviato Thu 08 May 14 @ 11:41 am
I have the same problem VDJ won't recognized wego

groovindj
PRO Infinity
Member since 2007

Inviato Thu 08 May 14 @ 11:47 am
Are you saying that the LE version supplied with the WeGO doesn't recognise it?