Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Beatport link - unknown file type - Page: 1
I'm using beatport link, some tracks when loading will randomly give the below error

unknown file type (invalid return value 0 for stream protocol)

The only solution is to sign out of beatport, sign back in (which sometimes crashes virtualdj (another issue !)

I'm on 5965 build (latest early access) but was happening with other builds consistently.

Inviato Tue 30 Jun 20 @ 1:05 pm
AdionPRO InfinityCTOMember since 2006
Is it always happening for the same song?

Inviato Tue 30 Jun 20 @ 1:08 pm
Once I sign out and back in the song will then load

Inviato Tue 30 Jun 20 @ 1:13 pm
Unfortunately this is making beatport link unusable, even signing out, then back in is only working 50% of the time, any logs I can look at ?

Inviato Tue 30 Jun 20 @ 8:58 pm
Just downloaded a free trial for RecordBox and logged into beatport Link, all tracks load with no issues, so it doesnt appear to be a pc / network issue - looks like its a VDJ problem.

Inviato Tue 30 Jun 20 @ 9:10 pm
Tried latest early access release, same problem.

Inviato Thu 02 Jul 20 @ 10:13 am
Build 5980 same issue.

Noticed that occasionally a track will take a long time to load, then the next track loaded will report the error.

Inviato Thu 02 Jul 20 @ 1:32 pm

Inviato Fri 03 Jul 20 @ 7:43 am
It's probably because of the speed you're loading tracks to the decks. Under what normal circumstances would anyone be loading tracks that fast?

It's a streaming service. The software needs time to communicate with the other end. Then the other end needs time to respond and send the data.

If you were using it normally - loading one track, playing it for a few minutes, then loading another one, it probably wouldn't be happening.

Inviato Fri 03 Jul 20 @ 8:11 am
Loading that fast was just an example - its nothing to do with the speed.

That was just an example of loading them till I hit the error, it can happen randomly on the first track I load or 5 tracks in it will happen.

Inviato Fri 03 Jul 20 @ 9:38 am
AdionPRO InfinityCTOMember since 2006
Can you try if after the error you really need to log out?
(So try if loading other songs work, and if loading the song that failed after then works too)

Inviato Fri 03 Jul 20 @ 9:45 am
Yep, so once a track has got the error it wont load again until I logout, even after loading other tracks. Other tracks will still load (unless they also hit the error).

Inviato Fri 03 Jul 20 @ 9:55 am
AdionPRO InfinityCTOMember since 2006
Could you try to remove Documents\VirtualDJ\Plugins64\beatport3_vdj_x64.dll and try again?
(It should be redownloaded automatically when opening VirtualDJ again)

Inviato Fri 03 Jul 20 @ 10:32 am
Just tried removing the plugin, it re-installed and got the same error after loading about 4 tracks.

Inviato Fri 03 Jul 20 @ 11:07 am
JeremK wrote :
Exact same problem here, on macOS.

Approximately 50% of the loaded tracks from Beatport Link give the "unknown file type (invalid return value 0 for stream protocol)

Good to know its not just me or my setup. What version are you on ?

Inviato Mon 06 Jul 20 @ 7:40 am
tmm1957PRO InfinityMember since 2006
I have the same problem. It looks like after one time playing this problem starts. I use beatport link a few days now.

Inviato Mon 06 Jul 20 @ 10:54 am
oliwynnPRO InfinityMember since 2004
I have the same issue on v8.4 b5874 - I don't have this issue with Deezer, only with Beatport Link

Inviato Mon 06 Jul 20 @ 10:57 pm
Yep same error happening for me. I spin breaks and it's hard enough to find the music I need for my sets. I still haven't found an answer to this issue. "Unknown file type (Invalid return value 0 for stream protocol)" on so many tracks! Somebody! Anybody! HHELLPPP!

Inviato Wed 08 Jul 20 @ 12:18 am
Any update from anyone ???

Inviato Fri 10 Jul 20 @ 9:22 am
I am having this exact issue - doesn't appear to be the case with Virtual DJ 8, but anything more recent (especially 2021) i get many errors and really causes me a kerfuffle when doing my live set

Inviato Fri 10 Jul 20 @ 3:47 pm
Pagina : [>] [>>]