Forum: Old versions

For older version, like VirtualDJ 7.

NOTE: VirtualDJ 7 is not maintained anymore.
Topic: Behringer CMD Studio 2A mapping - Page: 1

Questa parte dell'argomento è obsoleta e potrebbe contenere informazioni obsolete o errate

Just got mine today,, Is anyone Mapping this thing,, Im unable to map the touch-wheels,, any suggestions??

Inviato Wed 01 Oct 14 @ 3:19 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
CMD Studio 2A is not natively supported, so it will only work as a Simple Midi
Jogwheels, leds and possibly others will need a proper definition to work. In Simple Midi, buttons and sliders should work.
You will need to create a definition file .. see here..

Inviato Wed 01 Oct 14 @ 3:42 pm
thank you djdad,, Im dont really understand all the computer mambo jumbo ,, Ive tried mapping as a simple midi, but the mapping only work the deck in PFL..
pfl is selected on deck left deck,, both left and right controller levels only move the left side,, switch the pfl to the right deck,, control switches,, what am i doing wrong???

Inviato Wed 01 Oct 14 @ 4:38 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Behringer CMD Studio 2a is now a natively supported device in version 8.
You will need a VirtualDJ8 software build ending at .814 (or higher)

Thank you for your cooperation via Teamviewer.

Inviato Wed 01 Oct 14 @ 8:19 pm
Hello, good night! excuseme for my bad english but I've writed a support ticket because my cmd studio 2a don't work right with virtual dj 8.0.2191. It have 3 problems: 1 - LEDs don´t work, 2 - the 2 "load" buttons (LOAD A and LOAD B) load the tracks only in deck a (two buttons work for deck a and never load any track on deck b) and 3 - the cue and sample buttons are wrong mapped then they don´t work.
Please fix it, then cmd studio 2a will work right with virtual dj 8.

Inviato Wed 15 Apr 15 @ 9:09 pm
I'm waiting for the solution... Thanks!

Inviato Wed 17 Jun 15 @ 9:32 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Found the bug for the LOAD buttons, but cant see why the LEDS dont work or Samples and HotCue buttons.

We dont have the unit (we never had one) so the definition was based on the Documentation from Behringer and remote session with a user
According to these documents the unit should send the following MIDI messages.. (00/7F means 7F when pressed and 00 when released)
93 0A 00/7F .. HOTCUE1
93 0B 00/7F.. HOTCUE2
93 0C 00/7F .. HOTCUE3
93 0D 00/7F .. HOTCUE4
03 0E 00/7F .. SAMPLE1
93 0F 00/7F .. SAMPLE2
93 11 00/7F .. SAMPLE3
93 12 00/7F .. SAMPLE4

93 3A 00/7F .. HOTCUE1
93 3B 00/7F .. HOTCUE2
93 3C 00/7F .. HOTCUE3
93 3D 00/7F .. HOTCUE4
93 3E 00/7F .. SAMPLE1
93 3F 00/7F .. SAMPLE2
93 41 00/7F .. SAMPLE3
93 21 00/7F .. SAMPLE4 <----- This could be wrong. Expected would be 93 42 00/7F , please verify.

Please verify the above with Miditrace or MIDI-OX

Since we had verified the proper operation with a user via Remote session, either the unit was not properly detected and you are trying to use a simple Midi mapping or your software is not updated to the latest version.
Make sure you are running the latest build 2325.998 (has a fix for the LOAD buttons)

Inviato Thu 18 Jun 15 @ 2:11 am
Revisando con midi trace encuentro que cuando presiono cue 1 en el deck izquierdo aparece 93 OE 7F 00 y cuando lo suelto aparece 83 OE 00 00, lo mismo ocurre con el resto de los ejemplos que me mencionan en el foro, siempre al soltar los botones cambiael 83 por el 93. De todos modos la diferencia creo que esta en que el mapper por defecto los nombra HOTCUE_1, 2, ECT. Y SAMPLE_1,2, ECT. cuando deberia decir hotcue1, 2, ect y sample1, 2, etc. Cuando hago esa modificacion desde el mapeo se soluciona el problema con esos botones. Gracias.

Inviato Thu 18 Jun 15 @ 5:45 pm
Last version doesnt fix load buttons... Thanks for check it.

Inviato Thu 18 Jun 15 @ 6:24 pm
For sample4 is 93 42 7f 00 when pressed and 83 42 00 00 when released. Thanks.

Inviato Thu 18 Jun 15 @ 6:27 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Load buttons and Sample4 must have been fixed in the latest controllers update.
But you need to connect to the Internet and let VirtualDJ silently update the controllers version, which is the last 3 digits of the software version number e.g. xxxx.999. Confirm that from the SETTINGS (look at the top)
If you dont see 999 or higher, then something is blocking VirtualDJ from updating automatically.
Please make a clean installation of VirtualDJ 8 from here and dont use any unofficial installer from the Internet ;)

For the LEDS, you can confirm using MIDIOX (Send sysex from the menu) that sending 93 0A 7F turns the left HOTCUE1 led on and sending 93 0A 00 turns it off.

Last but not least, you will need a Pro Infinity, a Plus controller or a Pro Subscription license to work with your controller more than 10 minutes.

Inviato Fri 19 Jun 15 @ 6:52 am
Hello, now my virtual dj version is 2325.999, load button works fine. But any leds works, i dont fix it. Excuseme and thanks for you help...

Inviato Fri 19 Jun 15 @ 1:47 pm
Hotcues and samples dont work, because in the mapping says hotcue_1,2,3&4 and sample_1,2,3&4 but should says hotcue1,2,3&4 and sample1,2,3&4. Thanks.

Inviato Fri 19 Jun 15 @ 1:52 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Ah yes, you are right. HotCue and Sample buttons should work now in builds ending at xxxx.1000

for the Leds, please confirm with MIDIOX that sending 93 0A 7F, turns the left HotCue button and 93 0A 00 turns it off. (or 93 02 7F and 93 02 00 for the left PLAY button)
Instructions for MIDI OX
From the menu-->Options->Midi Devices.
Select the Behringer unit for both Midi Inputs and Midi Outputs. Press OK
From the top menu -->Actions-->Send-->Sysex File. Close the window that will open (dont choose any file)
Type 93 0A 7F in the Command window
From the menu of this window -->Command Window -->Send sysex

Inviato Fri 19 Jun 15 @ 2:19 pm
Hello, i try it and leds doesnt work. Load, hotcues and samples are ok! But only left than leds work... Thanks for your help, im waiting an idea...

Inviato Fri 19 Jun 15 @ 4:54 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Did you try with MIDIOX as instructed above ?

EDIT. Ok probably found the issue. The leds need value 01 instead of 7F to turn on.
Please try with builds ending at xxxx.1001

Inviato Fri 19 Jun 15 @ 8:08 pm
Excellent! I tried it and works fine! Thank you for you time, your help was very important. Thanks!

Inviato Sat 20 Jun 15 @ 1:57 pm
yojavi86 can you help me with the mapper for cmd studio 2a? i can't map it. please!

Inviato Wed 02 Dec 15 @ 8:19 pm
Read the thread. The CMD Studio 2A has been natively supported in VDJ 8 for over a year now.

Of course you will need a license if you wish to use it for more than 10 minutes.

Inviato Wed 02 Dec 15 @ 9:14 pm
Can you give me the download link for CMD studio 2a mapping

Inviato Tue 29 Mar 16 @ 9:31 am
Pagina : [>] [>>]