Forum: VirtualDJ 8.2 Technical Support

Use this forum to report any bug, questions or comment related to the latest version of VirtualDJ 8.2.
Forum Guidelines

(NOTE: VirtualDJ 8.2 is continuously updated, so many older topic on this forum are most probably already fixed in the current build)
Topic: Does not save label
I am trying to put my own key change notes in the label section of the tag. If I write the note in the tag editor, write tag, and save it, the note shows up right away. But, if I close and reopen VDJ8, the note I wrote into the label column does not display. What am I doing wrong?

Inviato 7 days ago @ 4:49 pm
AdionPRO InfinityCTOMember since 2006
And other fields are working fine?

Inviato 7 days ago @ 9:55 pm
Adion I do edit the Artist and Title quite often, and it always saves for me. But adding a comment in the label column does not save. It beats me....

Inviato 7 days ago @ 10:32 pm
just for testing...copy/backup the database first, then delete the database and try that exact file again.

It works for me.

I did some testing, I Attrib (flag) the file (it's a ZIP FILE/KARAOKE) READ ONLY and went to add a comment on the LABEL field and it saves.
This FIELD does not get written to the FILE itself (like the title/artist etc.. fields) but saves it to the database.


Inviato 7 days ago @ 12:11 am
Tried that Magic, it did not work for me. In these images, the first of which I went to the tag editor, wrote in a -3 note in the remix field, closed the editor, and the -3 note shows in the browser. Perfect! But when I close VDJ and reopen, you can see the -3 note is under the remix field for some reason, and the -3 note does not show in the remix column of the browser. I have tried adding this -3 note to the artist field, title field, label, and comments and the -3 note just will not display in the browser after closing and reopening VDJ. Ah, the ghost in the machine.:) v8.2 b3934

Inviato 6 days ago @ 2:22 pm
AdionPRO InfinityCTOMember since 2006
It sounds like the database is not saved at all.
Is the readOnly option enabled perhaps?

Other than that, check the file modified date of your database.xml

Inviato 6 days ago @ 4:31 pm
Adion the readOnly option was set at Yes. I did change it to No, and now it saves and displays the note properly!! You the Man! Thanks!

Inviato 6 days ago @ 4:42 pm