Forum: Wishes and new features

Features you would like to see in VirtualDJ
Topic: Effect Strength issue
When I use a controller pads to start / stop any kind of effect, then it's strength is always reset. Even if I pre-define it, it simply reset. When I use the skin and push the "pads buttons", then it reset the STR as well. However (and here comes the funny part), when I simply push the button where I can select / choose effects, it will not reset the strength. I can imagine two scenarios:
1.- Develop a possibility to pre-define the strength
2.- PADs buttons should not reset strength or at least there should be an option to choose the behaviour

However, both would be great. What do you think?

Inviato Wed 13 Mar 19 @ 4:58 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
How is the pad mapped ?

Inviato Wed 13 Mar 19 @ 8:07 pm
djdad wrote :
How is the pad mapped ?


Thanks for asking. The mapping is the default. Wheter I use my controller or not, I can re-generate the same symtom.
I could create a short video to demonstrate the situation if it would help to better understand my problem.

Inviato Thu 14 Mar 19 @ 7:05 am
djdadPRO InfinityDevelopment ManagerMember since 2005
By effects, perhaps you mean samples and the default Sampler pads psge ?

Inviato Thu 14 Mar 19 @ 7:12 am
djdad wrote :
By effects, perhaps you mean samples and the default Sampler pads psge ?


I'm talking about effects. I was able fix the sampler pads with made custom configuration buttons...

I've tried to make a short presentation video about the issue. If you need, I could demonstrate it more.
https://www.youtube.com/watch?v=eDrS4m3XD_U

Inviato Fri 15 Mar 19 @ 9:49 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Ah i see now, you were referring to the PartyMix PM FX Pads page.
Yes, those Pads have pre-defined parameter values, so they dont just trigger Effects. Reason made that way is because the PartyMix doesnt have Effect Parameter knobs and we wanted to ensure that they will sound decent regardless the previous parameter settings.
If you want the Pads to just trigger the Effect, you will need to edit the actions of the PM FX Pads with the Editor and get rid of the effect_slider actions

Inviato Fri 15 Mar 19 @ 10:33 am
The problem is still the same when I unplug the controller and trying the same. It will reset. How could I reconfigure this?

Inviato Sat 16 Mar 19 @ 7:15 am
djdad wrote :
Ah i see now, you were referring to the PartyMix PM FX Pads page.
Yes, those Pads have pre-defined parameter values, so they dont just trigger Effects. Reason made that way is because the PartyMix doesnt have Effect Parameter knobs and we wanted to ensure that they will sound decent regardless the previous parameter settings.
If you want the Pads to just trigger the Effect, you will need to edit the actions of the PM FX Pads with the Editor and get rid of the effect_slider actions


And is there any documentation available how could I reconfigure the PADS? Because it seems these parameters are hard-coded and I can see only PAD1 ... PAD4, but can not find how could I reconfigure it for Effects.


Inviato Fri 22 Mar 19 @ 7:34 am
djdadPRO InfinityDevelopment ManagerMember since 2005
With the PartyMix plugged, open VirtualDJ. Use the default skin, and from the Pads Page selection drop, select "edit" to open the Pads Editor.
Below is the Pads Editor showing the PM FX Pads page selected and the assigned action for Pad 2.



If you dont want the Pad to set the effect's Parameters, instead of having
effect_active 'Flanger' & effect_slider 'Flanger' 1 90% & effect_slider 'Flanger' 2 75%

, edit the action to just
effect_active 'Flanger'

Inviato Fri 22 Mar 19 @ 8:12 am
djdad wrote :
With the PartyMix plugged, open VirtualDJ. Use the default skin, and from the Pads Page selection drop, select "edit" to open the Pads Editor.
Below is the Pads Editor showing the PM FX Pads page selected and the assigned action for Pad 2.



If you dont want the Pad to set the effect's Parameters, instead of having
effect_active 'Flanger' & effect_slider 'Flanger' 1 90% & effect_slider 'Flanger' 2 75%

, edit the action to just
effect_active 'Flanger'


Thank you very much! Amazing! I have never found this possibility before. Wow! Works great now, thank you!


Inviato Mon 25 Mar 19 @ 7:49 am