Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: [Solved] Track Analysis Very Slow
I have a fast computer with 6 cores, an SSD, and 32 GB RAM running Windows 10 64-bit Pro.

I'm running the latest 64-bit beta of VDJ.

I just analyzed about 300 tracks for BPM, key and noticed that VDJ was analyzing one track at a time. In the past, I noticed several tracks at a time being analyzed.

Because of this behavior, it took 5-6 times the amount of time to do the job.

What changed?

Inviato Sun 21 Jul 19 @ 1:25 pm
AdionPRO InfinityCTOMember since 2006
Were you playing tracks during analysis? Was the video output active? Video playing perhaps?

Inviato Sun 21 Jul 19 @ 1:28 pm
Adion wrote :
Were you playing tracks during analysis? Was the video output active? Video playing perhaps?


No. I was not playing any music, on any app. Video was not active.

It's strange.


Inviato Sun 21 Jul 19 @ 2:21 pm
I went the extra mile:

1. Loaded the latest 64-bit beta on another Windows 10 machine
2. Downloaded some music

The analysis runs exactly the same: one file at a time.

If that is expected behavior, so be it. However, in past versions, multiple files were analyzed at the same time. I'm assuming this is done with the multiple cores of the processor.

However, the latest beta analyzes one file at a time.

Anyone know how I can step back my installation.

Inviato Mon 22 Jul 19 @ 12:03 pm
AdionPRO InfinityCTOMember since 2006
Which cpu do you have exactly?

Inviato Mon 22 Jul 19 @ 12:13 pm
Adion wrote :
Which cpu do you have exactly?


In my main machine, the first one that exhibited this behavior, I have Intel Core i7-7820X.

In the laptop that I just tried there is an Intel Core i7-7500U.

Is there a way to step back on the 64 bit betas?

BTW I tried the latest 32 bit version and it exhibited the same behavior.


Inviato Mon 22 Jul 19 @ 12:20 pm
locodogPRO InfinityModeratorMember since 2013

Inviato Mon 22 Jul 19 @ 12:34 pm
locodog wrote :
For public release x64 https://virtualdj.com/download/virtualdj8/pc64
but before you switch, check your songLoadPriority option


SongLoadPriority is "normal"

Is that the correct setting?

Can you guys confirm that what I am seeing is a bug, expected behavior or a user-related issue?


Inviato Mon 22 Jul 19 @ 12:38 pm
My 64 bit version (b5095) on my desktop still does the multiple file analysis, lightning fast. Intel i7 7700K 4.2GHz.

There must be some issue with your system.

Inviato Mon 22 Jul 19 @ 12:55 pm
FYI i7-7500u only has 2 cores so will probably only do 1 at a time on that machine

Inviato Mon 22 Jul 19 @ 12:56 pm
AdionPRO InfinityCTOMember since 2006
Still working fine here too.
The i7-7500U is indeed only a 2-core, so won't do multiple files at the same time.

From what I found the i7-7820X should be an 8-core, so that should indeed work.
Did you check task manager if windows correctly detects it as an 8 core?

Inviato Mon 22 Jul 19 @ 1:38 pm
Ok, a big "nevermind". Thanks for everyone helping me. I figured it out.

1. I noticed another app was only using 4 cores.
2. I googled "why is my processor using less than the total number of cores"
3. I checked the msconfig app and remember that when I was trying to fix slow boot times (which turned out to be due to a crappy USB 3 hub), I had altered a setting related to number of processors, under the Boot tab > Advanced Options. I had entered "4" as the number of processors.
4. So I unchecked that, and restarted.
5. Checked VDJ and the other app that was only using 4 cores, and both worked at their full core potential again.

I like to solve my own problems but, of course, I create some too. Sometimes at the same time.

Thanks again.

Inviato Mon 22 Jul 19 @ 1:47 pm