Forum: Wishes and new features

Features you would like to see in VirtualDJ
Topic: OPTIONEN / automixMode / fadelengh VDJ SKIPT
In the "Automix menu" there are various options for specifying the fade.
In some cases the "Fader time, GAP" is also used.

Please offer THESE function(s) as VDJ-Skipt, so that CUSTOMER-BUTTONs or Short-Cuts can be assigned, in order to be able to switch the transitions within different styles of presentation "service-friendly".

At the moment, it requires "a rather cumbersome opening of the menu, and then scrolling through the lines - once to select the ART, a second time to set the LENGTH.

It would be quite helpful to be able to have these functions executed as VDJ-SKIPT IN ONE COMMAND.

THANKS for noticing
DJF*******

Inviato Fri 15 May 20 @ 6:50 pm
setting 'automixMode' 'force fade'
'force fade' can also be:
'smart'
'skip silence'
'full song'
'no mix'
'radio'

setting 'faderLength' 4
Change the 4 into how many seconds you want.

All can be assigned to custom buttons.

Inviato Fri 15 May 20 @ 10:20 pm
SUPER for the tip and syntax - I couldn't have done it that way.

ADDITIONAL QUESTION: can the commands 'automixMode' 'force fade' and 'faderLength' 4 be combined in ONE BUTTON, with 1x CLICK?

What does the combination look like?

Inviato Sun 17 May 20 @ 10:12 pm
...mmmmh, begging for leniency, but THIS notation does NOT perform ANY action by ME!

A configuration previously entered manually in the "Automix-Menu" would have to be changed by pressing the Customer-Button according to the entry there - redefine it - but it does NOT do so.

This can also be checked in the list of OPTIONS.

What else am I doing wrong?

Inviato Sun 17 May 20 @ 10:32 pm
Are you writing the custom button including the word 'setting'? Like this:


And yes you can combine the actions using an '&' symbol, like this:

Inviato Sun 17 May 20 @ 11:47 pm
Hi Dan,
now it's complet!
You know it, I don't write the word "setting" additional - but yet it works! I'm happy for your help***

There is a question I in extention:
In the browser 'automix menu' all variants have to be selected, as well as in the OPTIONS > automixMode.

With the EXCEPTION: radio

What's it all about? It's not on the menu.

Inviato Wed 20 May 20 @ 2:56 pm
Hello, Dan,
I've got everything I need all set up right now.

CORRECTION, PLEASE:
1) setting 'automixMode' 'full songS'
2) setting 'fadeLength' (NOT 'fadeRLength')

How is "2 seconds gap" controlled?

E.g. setting 'fadeLength' 2 gap
or setting 'fadeLength' 2gap

results in "2s" ONLY, but NOT "2s Gap"


Inviato Wed 20 May 20 @ 3:44 pm
setting 'fadeLength' 2


Radio is the same as fade out.cut in (remove silence) from the menu.

Inviato Wed 20 May 20 @ 4:03 pm
AdionPRO InfinityCTOMember since 2006
Gap is negative numbers (so -2 is 2 second gap)

Inviato Wed 20 May 20 @ 4:46 pm
Hello, Dan,
THANK YOU for the really constructive support in all details.

But one more remark, which I have now tried out:
can only be written like this, ONE WORD 'fadeLength' .
mod, Fixed


Hello Adion,
my thanks to you for the addition.

...you have to figure it out with the negative numbers.

Best wishes & Happy Mixing

Inviato Wed 20 May 20 @ 8:41 pm
Hi,
analog to the previous dialog I tried to execute the command
setting 'resetPitchOnLoad' 'on' / 'off' ('yes' / 'no').
Unfortunately it does NOT work like this.

How to change the spelling so that the command line can be executed successfully?

Inviato Sun 07 Jun 20 @ 7:01 am
NicotuxHome userMember since 2014
setting value is a boolean, not a string, remove quotes:
setting 'resetPitchOnLoad' on
setting name is inherent string quotes can be omitted too:
setting resetPitchOnLoad on
possible values : on true 1 yes off false 0 no

Inviato Sun 07 Jun 20 @ 3:43 pm