Accesso rapido:  

Forum: VirtualDJ Technical Support

Topic: Weird jog bug - Page: 1
I had posted a comment on a similar topic but thought I should create a separate thread for this problem I'm having...
In that when I go for a scratch..the first(or first set of movements) on the touch jogwheel are not being 'registered' properly by the software...almost like the controller is nudging instead of scratching at happens mostly on the 1st attempted scratch on a newly loaded track or even on the same track if I leave the song idle for a few seconds.
This seems to be a v8.5 problem as v8.4 works perfectly..I tested the same songs and cue points to scratch on etc
The touch wheel setting was at 2.0 when I used 8.4 and hence the same in 8.5,all my ramp settings are on 0 and the backspin settings is also set to its lowest for no delay on release...
The controller is a ddj sb3 and works well with 8.4..I have tried master tempo off and all the pitch quality settings without any resolve...
Ps..the problem is at the 1st continues normally after.
I tried to explain this the best I can.
Thanks in advance!!

Inviato Sat 18 Jul 20 @ 4:10 pm
AdionPRO InfinityCTOMember since 2006
Might be useful to know which controller it's about :)

Inviato Sat 18 Jul 20 @ 6:27 pm
as i indicated in my initial post , its a ddj guessing all touch sensitive controllers although i am yet to see any other complaints from different users...but i think many users do not really do alot of scratching....

Inviato Sat 18 Jul 20 @ 6:31 pm
Do you have the stems feature turned on? If so, try with mathengine off.

Inviato Sat 18 Jul 20 @ 8:32 pm
The math setting is off

Inviato Sun 19 Jul 20 @ 12:20 am
So is no one else experiencing this problem?? I tried again today and it's clearly a bug as v 8.4 works perfectly

Inviato Thu 23 Jul 20 @ 2:04 am
djdadPRO InfinityDevelopment ManagerMember since 2005
First, are we talking about a backspin/scratch performed manually using the jogs, or about the hardware operated scratch/backspins from the pads in Scratch mode ?

Keep in mind that you will probably need to use one or the other way, because there is a VDJ setting that may lead one way or the other not to perform as expected.
This is the TouchWheelSpinThreshold, which we found working best at 2.0 value for the Scratch mode (and set by default for the SB3) , but the default value (0.8) should be much better when manually scratch/backspin.
Do you get the same issue with with both 2.0 and default (0.80) value ?

I tried to replicate your issue but couldnt. One thing you could do to troubleshoot, is to map a custom button as touchwheel_touch and observe if lights up briefly when you try to first-scratch with the SB3 jogwheels.. If not light up, then it could be some hardware issue.

Inviato Fri 24 Jul 20 @ 7:44 am
I have tried both values...0.8 and 2.0 and a whole lot of other values ranging from -1 to 1000 etc with no solution...and I did map the touchwheel_touch to a custom button...and it does light up and stay lit from the time I touch the jog until I let go...with no blinking to indicate that there is no hardware problem...also as I said it works perfectly in 8.4..try and have the scratch sensibility on something like 0.5 to on a high bpm track to replicate my issue..

Inviato Fri 24 Jul 20 @ 5:02 pm
Can u confirm this is only a 8.5 problem?
I saw something in the changelog about master tempo library updated...I don't know if this has anything to do with it...

Inviato Sat 25 Jul 20 @ 1:12 pm
I have noticed that the default spoken of threshold setting is back to 0.8 rather than 2.0 in previous this anything to do with the issue at hand...I haven't gotten around to plugging in a controller yet to test...

Inviato Thu 20 Aug 20 @ 5:51 am
i am still getting the problem with 6067...and i think it has something to do with some sort of scratch/jog drift....

Inviato Thu 20 Aug 20 @ 7:03 pm
AdionPRO InfinityCTOMember since 2006
Nothing changed regarding the touchWheelSpinThreshold. The default is still 0.8, and upon connecting the DDJ-SB3 it should change to 2.0 assuming it was not manually changed before.

Anyway, this option is related to release of the jog wheel, but your problem seems to be the first touch, so I don't think it will be related.

What you can check is in Options->Mapping select the SB3, and then see if JOG_TOUCH_CDJ or JOG_TOUCH_VINYL appear correctly on the right side when touching the jog wheel.

Inviato Fri 21 Aug 20 @ 6:54 am
ok..i have given it a solid troubleshooting session and i am about 75% sure the problem is the touchwheel_touch when the track is not playing..and i try to scratch('touchwheel' function in effect),all is's only when i play the track and try to "grab" the song to scratch..there is an audible(not visible,i'll explain) delay...and this delay is "transported"...meaning that it builds up and hence the drift i was talking about...
now i mapped "touchwheel_touch" to a custom button and the button is lit immediately on touching the jog(no visible problem)...but i can hear the delay before the grab.
as i have said before...there is no problem in this has to be a software bug...
because i have small jogs(ddj sb3),my jogsensitivity setting is pretty low at 0.6...
the problem should be easily replicated on low setting,,,as with the default setting of 1...the delay might not be heard as a bigger segment of the track is grabbed for forward and backward pushes and pulls.
i have math engine disables btw,all ramp settings on 0.000...
eagerly awaiting some positive feedback...even someone else that is having the i can rule out all other causes.

Inviato Fri 21 Aug 20 @ 5:07 pm
have you tried renaming settings.xml in documents/virtualDJ/

could be something in there

after you test you just delete the new one and change it back if there is no change

Inviato Fri 21 Aug 20 @ 7:02 pm
Yes I did all of this already...reverted to default settings and default mappings..with same results

Inviato Fri 21 Aug 20 @ 7:27 pm
Up to now no solution, same problem..and i'm planing going back to vdj2020 ...

Inviato Fri 11 Sep 20 @ 6:46 am
I see everyday videos releasing praising the new stems feature..and yeah we get's an exciting new feature to transform the DJ workflow...but this bug deals with a fundamental part of the basics..can we please have some feedback on this issue???

Inviato Fri 25 Sep 20 @ 3:33 am
AdionPRO InfinityCTOMember since 2006
Which is the last build that does work for you?

Inviato Fri 25 Sep 20 @ 5:35 am
ok reporting back....the latest non buggy version for me is build there were no early access builds between 5504 and 5630 available to download and i cannot say from where exactly things went south but i have a huge suspicion that it has to do with a highlight of an update that raised a red flag for me in the EA update log for build 5541: "Update pitch stretching library"....what exactly was done?
Just to note..when i saw this,i had tested newer builds without using master tempo when scratching and it made no difference with the bug...
It may be this or something else that has changed(and caused the bug),somewhere from after 5504...
hope this is helpful in solving this

Inviato Fri 25 Sep 20 @ 6:50 pm
Confirming the bug on the ddj-sr also....

Inviato Sat 03 Oct 20 @ 12:56 am