Accesso rapido:  

Forum: VirtualDJ Technical Support

Topic: Numark Mixdeck wont work with VDJ2021 in win10 x64 - Page: 1
makbakPRO InfinityMember since 2015
I was having fun with VDJ8 installed in win 7 having a Home plus license for Numark mixdeck. I upgraded to win 10 x64 and installed VDJ2021. The controler doesnot work with VDJ but is recognised by windows.
any ideas?
Installed latest asio drivers for the controller
 

Inviato Fri 28 Aug 20 @ 12:16 pm
Pretty sure it works, but just wrong settings somewhere ;-)

What is not working? No audio? or no control (aka if you press play in the controllers, does it start song in VDJ or not etc)
 

Inviato Fri 28 Aug 20 @ 2:44 pm
makbakPRO InfinityMember since 2015
asio drivers may be the problem. I want to try WASAPI but it requires another licednse?!! Shouldnt the same license work for one controller but different drivers?
 

Inviato Fri 28 Aug 20 @ 2:50 pm
makbakPRO InfinityMember since 2015
deck is not loading at all. In audio settings asio drivers are reconnecting all the time
 

Inviato Fri 28 Aug 20 @ 2:52 pm
makbak wrote :
asio drivers may be the problem. I want to try WASAPI but it requires another licednse?!! Shouldnt the same license work for one controller but different drivers?


Same license yes, asio or wasapi doesnt matter
 

Inviato Fri 28 Aug 20 @ 10:18 pm
makbak wrote :
deck is not loading at all. In audio settings asio drivers are reconnecting all the time


If its not loading at all, is there any message on deck? any error?

and post a screenshot of the sound settings in VirtualDJ (after you press apply same place).
Guessing that it shows "error" perhaps. And maybe the sound card of the Wego is already in use and taken, for example by Windows as its default sound card
 

Inviato Fri 28 Aug 20 @ 10:18 pm
makbakPRO InfinityMember since 2015
Rune (dj-in-norway) wrote :
makbak wrote :
deck is not loading at all. In audio settings asio drivers are reconnecting all the time


If its not loading at all, is there any message on deck? any error?

and post a screenshot of the sound settings in VirtualDJ (after you press apply same place).
Guessing that it shows "error" perhaps. And maybe the sound card of the Wego is already in use and taken, for example by Windows as its default sound card


no message decks are blank
 

Inviato Sat 29 Aug 20 @ 12:07 am
makbakPRO InfinityMember since 2015
when i change to wasapi it asks for licence!!!
 

Inviato Sat 29 Aug 20 @ 12:13 am
makbakPRO InfinityMember since 2015
also there is no out 3&4 option
 

Inviato Sat 29 Aug 20 @ 12:21 am
 

Inviato Sat 29 Aug 20 @ 12:23 am
wickedmix wrote :
because you need to set it to master and headphones

No I don't think so...

The second page of the VDJ setup guide says this:
"The entire mixer section of the Numark Mixdeck does not send MIDI signals to the software and works as analogue dj mixer, therefore none of the mixer section controls will control the VirtualDJ internal mixer and no movements will be visible on the GUI".


 

Inviato Sat 29 Aug 20 @ 8:17 am
makbakPRO InfinityMember since 2015
groovindj wrote :
wickedmix wrote :
because you need to set it to master and headphones

No I don't think so...

The second page of the VDJ setup guide says this:
"The entire mixer section of the Numark Mixdeck does not send MIDI signals to the software and works as analogue dj mixer, therefore none of the mixer section controls will control the VirtualDJ internal mixer and no movements will be visible on the GUI".




I agree about mixer control. the problem is the decks are not working at all. cant even load them.
 

Inviato Sat 29 Aug 20 @ 8:32 am
OK so when you look in the mapping area of config, do you see Mixdeck listed and selected?

When you use the Mixtrack deck controls, do you see any MIDI data in the mapping window?
 

Inviato Sat 29 Aug 20 @ 8:50 am
makbakPRO InfinityMember since 2015
groovindj wrote :
OK so when you look in the mapping area of config, do you see Mixdeck listed and selected?

When you use the Mixtrack deck controls, do you see any MIDI data in the mapping window?


in the mapping area of config, Mixdeck is listed and selected

no data on the mapping window
 

Inviato Sat 29 Aug 20 @ 9:46 am
I just found this on the Numark site:
"On Windows PCs, Logitech Webcam drivers interfere with virtually all brands and models of USB Audio or MIDI interfaces (like the MIXDECK)".

Has the computer ever had Logitech webcam drivers installed?
 

Inviato Sat 29 Aug 20 @ 10:19 am
makbakPRO InfinityMember since 2015
groovindj wrote :
I just found this on the Numark site:
"On Windows PCs, Logitech Webcam drivers interfere with virtually all brands and models of USB Audio or MIDI interfaces (like the MIXDECK)".

Has the computer ever had Logitech webcam drivers installed?


no never thank you for trying
 

Inviato Sat 29 Aug 20 @ 2:01 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
From manual ..
"Make sure that both channels on the mixer section of the MixDeck are set to PC and you have toggled each CD player to MIDI mode via the SOURCE button."
You' ve done this part, right ?

In VDJ Settings-->MAPPING tab, you see Mixdeck along with the keyboard, right ? If you select the Mixdeck, do you have the "factory default" option in Mapping on the right side , and the keys and their actions listed when selected ?
Do the pitch faders on the Mixdeck respond (moving the pitch faders of the skin) ?

As for the questions regarding Audio setup...
Yes, the Mixdeck needs "external mixer" audio setup (with deck 1 and deck 2), not Master+Headphones.
It shouldnt ask for any license if using WASAPI, but judging from the details of the ASIO showing just chans 1,2 i am guessing that the entire device is not properly detected.
Check Device Manager and see if you get any icon on Mixdeck device indicating failure in detection.

What else i would try...
1. With Mixdeck connected, make sure the Mixdeck audio is NOT the default playback device of Windows. (from Windows Sound)
2. Set it to quadrophinc (4 speakers) if not already set that way (from Windows Sound)
3. Try a different USB port and/or cable
4. Re-install the ASIO driver
 

Inviato Sat 29 Aug 20 @ 4:40 pm
makbakPRO InfinityMember since 2015
djdad wrote :

What else i would try...
1. With Mixdeck connected, make sure the Mixdeck audio is NOT the default playback device of Windows. (from Windows Sound)
2. Set it to quadrophinc (4 speakers) if not already set that way (from Windows Sound)
3. Try a different USB port and/or cable
4. Re-install the ASIO driver


tried everything except Set it to quadrophinc as i dont know how/ nothing works. it does not communicate as midi controler at all I think
 

Inviato Sat 29 Aug 20 @ 8:46 pm
kerimramControlleristMember since 2007
I am having the same problem with all my x10 installation.

Did you find any solution for your problem.

I keep using it with a W7 laptop with VDJ 2020 version and it is quite annoying not to find a solution to that:(

 

Inviato Sat 13 Mar 21 @ 9:46 am
I was having the same issues and got no help from Numark! FIXED on my own!

This took me 24 grueling hours but here's the scoop:

Installed drivers on a new Laptop w/ Windows 10 (2.9.64) 64bit. Be sure to power down the numark mixdeck, turn it back on, then plug in the usb cable prior to running the installer. If the installer does not detect the mixdeck - you should restart the computer and turn off the Mixdeck and turn it back on prior to plugging in the usb cable and re-installing.

Do NOT restart the computer like it says... (ugh!!) This took me forever to figure out... Just click Restart Later.

At this point, go to Device Manager (start menu, type device manager, click it!)

Under "Sound, Video, and Game Controllers" you should see Numark MixDeck Audio - WDM 2.9.64.... right click on this and DISABLE. I know, you will get a warning but just say OK. You will then see an image with a speaker with a down arrow on it (next to the words of Numark MixDeck Audio - WDM 2.9.64) - this means it is disabled.

Basically, this should turn off the Numark Mixdeck from trying to run as an external soundcard (this conflicts with the laptop soundcard). You should still see Numark MixDeck MIDI 2.9.64 (good!) and under Universal Serial Bus controllers, you should see Numark MixDeck USB 2.9.64 (good!)

Now when you restart, you won't get a bunch of USB errors!
 

Inviato Tue 11 May 21 @ 6:33 am
83%